読者です 読者をやめる 読者になる 読者になる

Lubuntu 14.04 に Ruby 2.2 をインストールする

Ruby Linux

Lubuntu 14.04 で Ruby を使いたければ、sudo apt-get install ruby で一応可能だが、これだと古いヴァージョン(僕の場合だと Ruby 1.9.1)が入ってしまう。今のところ最新の、Ruby 2.2 を入れてみた。参考にしたのは
  Ubuntu 14.04 に apt-get で Ruby 2.1 をインストールする方法 - Rails 雑感 - Ruby on Rails with OIAX
で、ここでは UbuntuRuby 2.1 を入れているが、自分の場合でもまったく同様にできた。上のサイトを見たらいいが、一応メモとして書いておく。コマンドラインから

$ sudo add-apt-repository -y ppa:brightbox/ruby-ng
$ sudo apt-get update
$ sudo apt-get -y install ruby2.2

で OK。インストールが終ったら、ruby -v でヴァージョンを確認、インストールされていればお仕舞い。